Parade Help Center Down

Incident Report for Parade

Resolved

Our Help Center is back and active.
Posted Apr 01, 2025 - 13:11 UTC

Identified

We have identified the cause behind the unavailability of our Help Center and are actively working with the responsible team to fix it. Meanwhile, please reach out to support@parade.ai directly in case of necessity.
Posted Mar 31, 2025 - 14:45 UTC
This incident affected: Help Center (Help Center).